Trouble with Libby and Online Catalogue?

If you are having trouble getting connected to Libby or placing holds on our Online Catalogue, please call the Library at 705-356-7616!

Get Our Apps - Kingston Library

Libby is now the new OverDrive.

  • Libby’s minimum iOS version is now iOS 10. To use Libby on an iOS device, users are required to update their device’s operating system to iOS 10 or newer.
  • The legacy OverDrive for Mac desktop app is only supported on macOS versions 10.12.1 through 10.14.
  • Users on legacy web browsers may experience issues loading libbyapp.com or your OverDrive website and should upgrade to a newer browser version, if possible.

Patrons can contact Libby directly using the web form or the “Get some help” option in Libby

Print Friendly, PDF & Email
Total Page Visits: 2086 - Today Page Visits: 1